Xtreme Weather Discord - Minecraft Server Issues – Incident details

All systems operational

Minecraft Server Issues

Resolved
Degraded performance
Started 7 months agoLasted about 4 hours
Updates
  • Resolved
    Resolved

    Our Minecraft server has been back up and running for a few hours now, we apologize for the inconvenience.

  • Investigating
    Investigating

    We're currently investigating into our Minecraft server being sporadically unavailable.